Bienvenido a la Comunidad UBNT

Problema latencia L2 Airmax AC Mixed

Buenos Días amigos, tengo un problema con la latencia en un entorno AC mixto. He intentado ver posibles causas pero no encuentro algún indicio

Acabamos de instalar una Sectorial LiteBeam de 120 grados, para un pequeño sector donde utilizamos LBE-M5 o NanoBeam.
Nos ocurrió que al momento de instalar un cliente con LBE-M5, los speedtest no superaban los 2Megas, siendo que el enlace presentaba buenos valores al igual que la latencia.... Luego de realizar muchas pruebas, actualizamos firmware, cambiamos equipos por unos nuevos, realineamos y encontramos lo siguiente..

Algo ocurre con la latencia en L2 del enlace en entorno mixto. Si realizamos un ping con icmp no muestra problema alguno, un mínimo aumento de latencia, pero si realizamos los pings con ARP (directamente en capa2) nos entrega una latencia terrible al mover trafico en el enlace. Al parecer airmax trae un qos incorporado, adicional al marcado dscp, que distingue paquetes icmp y los prioriza.. pero al utilizar arp muestra la latencia real.
Lo malo de esta situación, es que realizamos el cambio del AP AC a un rocketM5 que teníamos en bodega y desapareció el problema, sin tocar nada en el cliente

Adjunto unas imágenes de las latencias obtenidas (usando ICMP y ARP, a mismo equipo) y del AP LBE--AC-120

Quedo atengo a cualquier información adicional que necesiten

Saludos
ORF
  

Comentarios

  • la retrocompatibilidad ( no se si exista esa palabra  :-?) modo mixto, siempre debemos tener en cuenta que los equipos son diseñados para trabajar en un entorno ya preestablecido, cuando intentamos conectar equipos M5 con AC, siempre debemos tener en cuenta:

    1. si entre los equipos cpe (clientes) hay equipos 1x1 (no mimo) el radio AP trabajara a este nivel. (asi el AP sea 2x2)
    2. siempre hay que actualizar a las ultimas versiones tanto de M5 y AC.
    3. la alineación de los cpe debe ser aun mas primordial, inclusive el fresnel debe ser mas limpio...
    4. la latencia depende demasiado de los niveles (ccq - fresnel - alineación - espectro) óptimos para así dar el mayor rendimiento posible.
    5. si en tu AP, tienes clientes a niveles normales (55 - 65) pero hay un solo cliente en niveles pésimos (70 - 80), el AP trabajar a nivel de este ultimo cliente, el airmax ( tiempo de respuesta) sera mas lento para todos los demas... (pin - velocidad - modulacion)
    6. utilizar mucha potencia es tan perjudicial como no tener linea de vista... mucho PIRE desestabiliza el canal y la calidad de la modulación.

    estamos al tanto...


  • Finalmente encontramos el problema... era algo independiente de la parte inalámbrica pero muy curioso. Es una red con 3 nodos en modo bridge, ocurría que la ip asociada tenía un ARP estatico, que no correspondía a la MAC del router del cliente, pero por algún motivo si se comunicaba el cliente mediante el uso de broadcast.. que se difundió por toda la red. Al parecer los equipos ubiquiti tienen algún limite, supongo de seguridad o QoS, que limita el broadcast que puede pasar por un AP, esa era la velocidad que se recibiamos  en el cliente y por eso al exigirle más ancho de banda, la latencia a nivel de capa MAC aumentaba (ya que el broadcast utilizaba toda la "cola" de tráfico no ip, por la cual va arp posiblemente ).
    Nos dimos cuenta, al observar las graficas en aircontrol, que todos los clientes de los otros nodos, tenían un tráfico adicional, de la misma velocidad que la navegación del cliente.. por lo que si el cliente navegaba con 2Megas, en todos los CPE se observaba un tráfico de 2MB en su parte RX y 0 en la parte de TX


    Interesante, pero se solució al actualizar el ARP estatico, con la MAC del router que correspondía al cliente. y con eso el Airtime Descendió de 50% a 5-10% y el cliente con sus 8Mb


    Saludos 

    ORF

Accede o Regístrate para comentar.