Bienvenido a la Comunidad UBNT

UNIFI Controller on ARM64

cyranincyranin 1 Point
editado abril 2019 en UniFi Wireless
Hola a todos,
Después de muchos problemas al intentar instalar Unifi Controller en la computadora Pine Rock64, (Arquitectura Arm64), lo instalé después de compilar los paquetes. Para ser breve, el principal problema es que el paquete Unifi para la arquitectura deb tiene una dependencia rota con Linux en la arquitectura ARM64.

mongodb-server (> = 2.4.10) | mongodb-10gen (> = 2.4.14) | mongodb-org-server (> = 2.6.0),
  mongodb-server (<< 1: 3.6.0) | mongodb-10gen (<< 3.6.0) | mongodb-org-server (<< 3.6.0),

Pero estos paquetes en esta versiones no están disponibles para ARM64  ya que hay versiónes más recientes disponibles. Así que eliminé estas dependencias, recompilé el binario e instalé. recuerda instalar dependencias y también el último servidor mongodb disponible.
Compilé la última versión disponible 5.10.20. Por favor, siéntase libre de descargar e instalar.


Hello All,
After a lot pf problems trying to install Unifi Controller on Pine Rock64 computer, (Arm64 Architecture), I sucesfully installed after re compiling the packages. To be short on this, the main problem is Unifi package for deb architecture has a broken dependency with linux on ARM64 arch.
mongodb-server (>= 2.4.10) | mongodb-10gen (>= 2.4.14) | mongodb-org-server (>= 2.6.0),
 mongodb-server (<< 1:3.6.0) | mongodb-10gen (<< 3.6.0) | mongodb-org-server (<< 3.6.0),
But this packages in this versions are unavailable from ARM64, (Newer version available). So I removed this dependencies, recompiled the binary, and installed. remeber to install dependencies and also last mongodb server available.
I compiled last version available 5.10.20. Pleasde feel free to download and install.


Contact me if you have doubts and sorry for my poor english
Regards!

Cyranin



Etiquetado:
TRuHa

Comentarios

  • TRuHaTRuHa 0 Puntos
    Grandísimo aporte Cyranin.

    Llevo unos días peleándome con este problema sin solución, lastima que tu versión no esté actualizada.

    ¿Podrias dar unos breves pasos para compilar y así tener la versión actualizada? Al menos las fuentes.

    Dentro de mis conocimientos en Linux se me escapa este tema y me gustaría aprender.

    Te doy mil gracias por el aporte, al menos con esta solución se hace funcional en un ARM64.

    Un saludo.
  • gedas07gedas07 0 Puntos
    Muchas gracias por tu aporte 
    Hola estoy intentando instalar el controlador de unifi en una rock64 con bionic instalado , y soy incapaz de que arranque, se me queda en el controlador esta iniciando espere un momento y asi lleva 4 horas, me puedes ayudar por favor ?
    he instalado tu deb  , pero no se si he de hacer algo mas 
Accede o Regístrate para comentar.