Bienvenido a la Comunidad UBNT

Problema al adoptar en capa 3

Hola, estoy intentando Adoptar en capa 3 y a pesar de que tengo el puerto 8080 abierto en router y dirigido a la cloud key no consigo que funcione.
Explico como lo tengo:

Cloud Key Gen2 (Actualmente en casa con router de ISP doméstico para hacer pruebas) IP: 192.168.1.100
Puertos abiertos en el router a la ip de la cloud key (192.168.1.100) = 8080 y 8443

Desde mi trabajo, uso un UAP LR reseteado de fábrica e intento primero por SSH usando putty con el comando: set-inform http://ip.publica.casa:8080/inform (donde evidentemente pongo la ip pública de mi casa)

Al ejecutar el comando, da el mensaje correcto, pero en la controladora de mi casa no aparece el UAP para poder adoptarlo.
----------------------
Luego intento hacerlo con con la APP en el movil de Unifi Network, consigo instalar la controladora remota que está en la cloud key de mi casa atacando a la ip pública sin problema, veo y configuro en el movil lo que quiera, pero cuando voy a Adopción Remota e intento adoptar el AP, lo intenta y me da "Adopción Fallida"

Creo que no me olvido nada, pero no se si os ha pasado y me estoy dejando algo atrás.

Saludos y muchas gracias de antemano.
Etiquetado:

Comentarios

  • Hola puede ser que necesites abrir los puertos necesarios 

    https://help.ubnt.com/hc/en-us/articles/218506997-UniFi-Ports-Used
  • Hola Ricardo, gracias por tu aporte, acabo de abrir los puertos que aún no tenía abiertos, de la lista de ese artículo que me envías, en lo referente a L3. Me he conectado a mi oficina y he lanzado un set-inform al AP que dejé encendido. Lamentablemente sigue sin aparecer en la controladora para poder adoptarlo.
  • Tienes forward o dmz la ip pública hacia tu controlador ?
  • BernardoruizBernardoruiz 0 Puntos
    editado septiembre 2019
    Si, exacto, todos esos puertos han sido abiertos a la ip .100 que es la del cloud key como he explicado arriba. De hecho se están abriendo, si no, no podría configurar la Controladora en la APP del móvil en el exterior de mi casa como es el caso. Como comenté, en la APP configuro la controladora atacando a la ip pública y funciona. La controladora usa el puerto 8443 pero ambos están abiertos el 8443 y 8080, bueno y también después los demás que ví en el enlace que me enviaste. 

    La cloud key es nueva, recién abierta, entiendo que en el system.properties los puertos son los genéricos no? En principio creo que lo veo correcto, no se si se me escapa algo:

    #

    # each unifi instance requires a set of ports:

    #

    ## device inform

    # unifi.http.port=8080

    ## controller UI / API

    # unifi.https.port=8443

    ## portal redirect port for HTTP

    # portal.http.port=8880

    ## portal redirect port for HTTPs

    # portal.https.port=8843

    ## local-bound port for DB server

    # unifi.db.port=27117

    ## UDP port used for STUN

    # unifi.stun.port=3478

    #

    ## the IP devices should be talking to for inform

    # system_ip=a.b.c.d

    ## disable mongodb journaling

    # unifi.db.nojournal=false

    ## extra mongod args

    # unifi.db.extraargs

    #

    ## HTTPS options

    # unifi.https.ciphers=TLS_RSA_WITH_AES_256_CBC_SHA,TLS_RSA_WITH_AES_128_CBC_SHA

    # unifi.https.sslEnabledProtocols=TLSv1,SSLv2Hello

    # unifi.https.hsts=false

    # unifi.https.hsts.max_age=31536000

    # unifi.https.hsts.preload=false

    # unifi.https.hsts.subdomain=false

    #

    # Ports reserved for device redirector. There is no need to open

    # firewall for these ports on controller, however do NOT set

    # controller to use these ports.

    #

    # portal.redirector.port=8881

    # portal.redirector.port.wired=8882

    #

    # Port used for throughput measurement.

    # unifi.throughput.port=6789

    #


  • Vale, acabo de encontrar el problema y he conseguido que funcione. Lo comparto por si a alguien le pasa.

    Viendo lo raro que era el tema ya y revisando a fondo una vez más el firmware del router doméstico, he visto que tiene la posibilidad de administrar remotamente el router y adivina que puerto usa? El dichoso 8080, por lo que al ser remoto este puerto ya está usado desde el exterior. 



    Lo que he hecho para no tocarlo no vaya a ser que el ISP lo utilice, es hacer un reenvío del puerto 9090 externo al 8080 interno a la ip de la Cloud Key. He lanzado el set-inform pero esta vez usando el puerto 9090:

        http://ip.publica.casa:9090/inform

    Y apareció sobre la marcha en la controladora de mi casa para poder adoptarlo. Elegí el site donde quería ponerlo y se adoptó sin ningún problema.



    Bueno, es simple, después de haberse dado uno de leches, pero como hay miles de routers en el mercado, ahí lo dejo por si a alguien le pasa.

    Saludos!

    PD. Ricardo, gracias igualmente!
Inicia Sesión o Regístrate para dejar un comentario.